Back to overview
Degraded

System performance degraded

May 21 at 10:07am CEST

Resolved
May 21 at 11:03am CEST

We are pleased to report that the system is now fully operational and all services have been restored. Thank you for your understanding.

Updated
May 21 at 10:33am CEST

We have identified the root cause of the ongoing issue and are actively working to mitigate it. Thank you for your patience as we implement the necessary steps for resolution. Further updates will be provided as they become available.

Created
May 21 at 10:07am CEST

We are currently experiencing degraded performance across parts of our system. Some users may notice slower response times or delays in data updates. Our team is actively investigating and working to restore normal performance levels.